Xsara 1.9TD Aircon fault.

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

User avatar
fastandfurryous
Posts: 1383
Joined: 07 Jul 2004, 17:57
Location: On the road, travelling at high speed. Meep Meep.
My Cars:
x 3

Xsara 1.9TD Aircon fault.

Post by fastandfurryous » 01 Jul 2013, 17:01

Hello all. Not posted here in a very long time, but then I've not had a french car in a very long time!

.. and this fault has foxed me somewhat.

Car is a Xsara 1.9 TD exclusive with climate control.

If you poke the A/C button, the light comes on, but the compressor clutch doesn't engage. System is full of gas. The pressure switch appears to be working correctly, as two pins have continuity, which appear to to be the low pressure part of it, and the other two pins do not have continuity (and if you bridge them, the fans go full-power, so that's clearly the high-pressure part)

So what next to check? The interior fan works (both in auto and manual) and it appears to detect the car interior temperature as the auto-fan-speed changes accordingly, and the outside air temperature is currently +25ish.

I must be missing something....
0x
This is not a signature.

addo
Sara Watson's Stalker
Posts: 7104
Joined: 19 Aug 2008, 12:38
Location: NEW South Wales, Australia. I'll show you "Far, far away" ;-)
My Cars: Peugeot 605
Citroën Berlingo
Alfa 147
x 2

Post by addo » 02 Jul 2013, 04:02

Jump 12V to your compressor and see if it runs.

Is the system overfilled?

Follow the compressor clutch supply wires back to the relay or relay panel. Is it a multiplexed car?
0x

User avatar
fastandfurryous
Posts: 1383
Joined: 07 Jul 2004, 17:57
Location: On the road, travelling at high speed. Meep Meep.
My Cars:
x 3

Re: Xsara 1.9TD Aircon fault.

Post by fastandfurryous » 02 Jul 2013, 13:51

Not a multiplexed car (thankfully!)

Jump 12V to the compressor... Clunk and it engages.

Don't think it's over-full as the system used to work and it's not been filled since then. If anything it would be a bit low on gas, but the pressure switch indicates that the pressure is above minimum, even at system rest, so it can't be low. (and even if it was, the switch would not be inhibiting the system.

Is there a relay that turns on the compressor? Unfortunately I don't have a wiring diagram.
0x
This is not a signature.

User avatar
fastandfurryous
Posts: 1383
Joined: 07 Jul 2004, 17:57
Location: On the road, travelling at high speed. Meep Meep.
My Cars:
x 3

Re: Xsara 1.9TD Aircon fault.

Post by fastandfurryous » 07 Jul 2013, 15:02

Ok, this gets more wierd.

The A/C will run, for about 8 minutes, only from a cold start. I've pulled the frost thermistor out, so that it never goes cold. I've also bypassed the HP and LP switch, mainly to prove a point. and still the A/C will only run for about 8 minutes, then cut out never to operate again until you leave the car for a few hours.

Is there an A/C electronic control unit? I am beginning to suspect this is not a sensor but a control system failure.
0x
This is not a signature.