Possible C3 Hdi Air Con Issue ?

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

eimaj12000
Posts: 4
Joined: 04 May 2010, 12:22

Possible C3 Hdi Air Con Issue ?

Post by eimaj12000 » 28 Oct 2012, 04:36

Hi,

I have a C3 1.4 HDi (8HX engine) and have a strange problem which I think may be air con related. The cooling fan on the car stays on permanently until the battery is flat with ignition on or off ? I've scoured the web for a solution to this but can't seem to find what would cause this. Have run diagnostic with Lexia and picks up no faults with temp sensor etc. The instrument panel temp sensor seems to work sensibly and from what I see there is only one coolant sensor on this engine (green one) ?

Also, I notice the radiator has two connectors - one is two wire and supplying 12V all the time (ignition on or off) and the other is three small wires which i take it are signals from ECU to control fan. Now, is it possible that something inside the fan requires repair (is there some kind of diode arrangement perhaps and a diode has blown)? It seems the web is full of experts on the engine, common rail etc. but I have yet to see someone explain how this fan system works - can't seem to find any relays or similar that could be stuck ?

Any help would be great.
[-o<

User avatar
myglaren
Forum Admin Team
Posts: 14755
Joined: 02 Mar 2008, 14:30
x 343

Re: Possible C3 Hdi Air Con Issue ?

Post by myglaren » 28 Oct 2012, 08:38

To avoid confusion please post replies in this identical thread here