Xantia aircon problem

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

medovski
Posts: 5
Joined: 09 Jul 2012, 11:45
Location:
My Cars:

Xantia aircon problem

Post by medovski » 10 Jul 2012, 12:03

Hi everybody,
I have a problem with my Xantia 1.6i,

The aircon is the newer type with the automatic fan speed control.
Two years ago I started having problems with my aircon.
It has been to 9 different garages, 4 citroen, 4 aircon specialists and 1 electrician.

During the winter it works like a machine gun, on-off-on-off, it really sounds like a machine gun.

In the spring it worked fine for about three weeks.

Now in the summer it works when I start my car for some time and then stops. If I want to start it again I rev the engine to 5000rpm and it starts, works for a few minuts and stops again.

Over the last two years I have changed these parts:

aircon ecu
temp. sensor - in the cabin with the little fan
dryer
pressure switch
bitron
relay
fan relays
engine ecu
engine temp. sensor which sends the signal to the engine ecu
electromagnet on the compressor


The aircon doesn't leak, It has been filled 5-6 times in the last two years.

I once gave the compressor 12V from the battery and it blew the gas throught the press. switch.

The compressor dissengages the clutch but there is 12V on the connector on the compressor.

Also when he aircon is on, the car runs bad. When I move my leg from the gas pedal it sometimes stays stuck at 2000rpm for a few seconds.

I really dont know what is the problem any more.

Please, tell me if anybody had something similar with his car or if you have any idea what could be wrong.

P.S. It is a 1999. MK2 Xantia with a 1600ccm engine in exellent condition and has been in my family since it was new so I know everything that was done to the car.
0x
Xantia Mk2 1.6i
Xantia Mk2 V6 Exclusive Break
Saxo Mk1 VTS 1.6i 16v