'99 Peugeot 206 1.9d green light only

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

Edhertz
Posts: 87
Joined: 19 Apr 2010, 17:51
Location: Colchester, Essex
My Cars:
x 2

'99 Peugeot 206 1.9d green light only

Post by Edhertz » 10 Aug 2011, 19:43

Here's hoping someone can help me with this one. My '99 Peugeot 206 1.9D's air con does not work. Took car to Kwick Fit who said that they found a low refrigerant level in the system. They topped it up, but could not get it to work so they kindly didn't charge me. This is what I have at the moment: green light comes on when the a.c switch is made , no compressor engaged or fans running, belt is driving ok. I pulled the connector and found no power to the compressor clutch. Removed the pressostat connector and bridged the two thicker wires (beige and pink) and the condenser fans came on, with no power to the clutch. Checked all fuses and relays and they are healthy. Thinking it could be disconituity in the wiring or one of the system sensors gone down. Any ideas anyone? Thanks for looking, Alan
0x

Greasy
New User
Posts: 1
Joined: 18 Jul 2012, 20:18
Location:
My Cars:

Re: '99 Peugeot 206 1.9d green light only

Post by Greasy » 27 Jul 2012, 19:45

Check the pressure sensor if the correct presuure is not sensed the compressor clutch will no activate

hope this helps
0x

addo
Sara Watson's Stalker
Posts: 7104
Joined: 19 Aug 2008, 12:38
Location: NEW South Wales, Australia. I'll show you "Far, far away" ;-)
My Cars: Peugeot 605
Citroën Berlingo
Alfa 147
x 2

Post by addo » 29 Jul 2012, 00:01

Also, a no-spin condition on the cabin fan will result in no signal to the compressor.

Did Bodgy-Fit leave the gas in, or restore it to the original pressure as measured?
0x

Edhertz
Posts: 87
Joined: 19 Apr 2010, 17:51
Location: Colchester, Essex
My Cars:
x 2

Re: '99 Peugeot 206 1.9d green light only

Post by Edhertz » 02 Aug 2012, 21:03

Firstly thanks for replies. Havn't done much more as regards finding the fault to tell you the truth. Weather has been so damn lousy we have not missed it. Things are going critical now, however, because the boss ( her car) informed me that the blower has stopped working so I've got to come up with something. So to recap: system gassed up, now no green light showing when a/c switch is made and no fuses blown. From memory: no voltage at prestat, continuity through the presstat so a 12v fly lead to should engage clutch but I have not tried this yet. Funny how the blower should wrap up at this time unless there is wear in a section of harness. Before I go does anyone know where the aircon relay is?
0x
Alan
1999 Xantia Exclusive 2.0Hdi Mauritius blue
1999 Peugeot LX 1.9D silver