When I turn the A/C on the temp light flashes??

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

Chris_300
Posts: 5
Joined: 18 May 2010, 14:21
Location: S. Wales
My Cars:

When I turn the A/C on the temp light flashes??

Post by Chris_300 » 14 Jun 2010, 10:23

I have a 2.0 HDI 2001 Synergie and this has only just started happening.

Even when you first start the car and it's cold if you have the A/C on the temp light flashes like it's overheating when it's not. Have checked all water levels etc and they are good, anyone else come across this?

Thanks Chris
0x

wheeler
Posts: 3516
Joined: 21 Sep 2002, 19:07
Location: United Kingdom
My Cars:
x 49

Post by wheeler » 14 Jun 2010, 11:46

This is usually caused by a fault with the cooling fan. Sometimes a faulty of siexed motor or the motor is missing power. Do both the cooling fans come on when the A/C is switched on ?
0x

spannertop
Posts: 1
Joined: 21 Jun 2010, 20:27
Location:
My Cars:

Post by spannertop » 21 Jun 2010, 20:32

I have a similar problem, in that approx 90 seconds after the air con is switched on, the temperature guage hits maximum and stays there. Prior to this happening the air con works, but afterwards it doesn't.
Could this also be the cooling fan?
0x

pazauk
Posts: 50
Joined: 09 Apr 2004, 02:25
Location: United Kingdom
My Cars:

Post by pazauk » 22 Aug 2010, 12:10

Did you get your air con working again? I have the same prob on my c3
0x
pazauk

citroenxm
Posts: 8015
Joined: 31 Dec 2004, 00:10
Location: I WISH I KNEW!!!!. Somewhere in North Wales, Anglesey
My Cars: 93 L Xantia TD SX anti sink
H 91 XM V6 24v PRV Manual
K 93 XM V6 12v SEi auto LPG

55 C5 1.6 HDi VTR
L 94 XM 2.1 TD auto
51 C5 LX HDi 2.0 auto
x 18

Post by citroenxm » 11 Nov 2010, 16:09

Ive come accross the Flashing light on Xantia HDi's

Its signalling engine over temperture... HOWEVER, it can also be triggered by a Faulty Relay.

I had this on a W reg Xantia HDi, after a Lexia session, the "Slow Running Fan" relay curcuit was short out... so there was no slow running fans available, so, on the xantias the 3 relays are located between the fans behind the grill, after a bit of time found that one of the terminals on the slow relay SOCKET was burnt out... I managed to get a replacement terminal on the end of the wire, after a bit of messing, re fitted the relay and all was fine again!

Paul
0x
1991 XM 3.0 24v Manual (x2)
1994 XM 2.1 d auto (undecided what to do now)

1994 Xantia TD SX Project
s**t thats scarey... two XMs left...