Needing recharged already!?

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

R9UKE
Posts: 1073
Joined: 21 Mar 2010, 22:18
Location: Belfast, N.Ireland
My Cars:

Needing recharged already!?

Post by R9UKE » 24 May 2010, 15:28

Hi,

I got the air con regassed on my 2003 Mégane in May last year by Kwik Fit. It's been used regularly as it automatically comes on with the demisting programme so was on quite a bit in winter. But now that the weather has got hot, it's hopeless. There is no difference with the AC on or off. I can hear it kicking in, but the air is not cold!

Is this normal for it to be needing done once a year?
I've also tried one of those air con cleaners - no difference.

I recieved a letter from Renault saying they regas for £49 (Kwik Fit is £45), so I was thinking of booking it in - but not if it needs a repair first!
Could there be a leak?

Oh and it's the digital automatic climate control by the way, not just the regular AC button.

Thanks.
0x
French is best.

User avatar
Xaccers
Posts: 7655
Joined: 08 Feb 2007, 00:46
Location: Milling around Milton Keynes
My Cars:
x 2

Post by Xaccers » 24 May 2010, 21:46

I'd say there's a leak
0x
1.9TD+ SX Xantia Estate (Cassy) running on 100% veg
1.9TD SX Xantia Hatchback (Jenny) running on 100% veg for sale
Laguna II 2.0dCi Privilege (Monty)

DIY sphere tool

User avatar
Citroenmad
Posts: 8111
Joined: 04 Dec 2008, 23:08
Location: Northeast
My Cars:
x 1

Post by Citroenmad » 25 May 2010, 13:26

If the AC is cutting in but its not cool then it sounds like there is a leak in the AC system.
0x
Chris
16 C4 Cactus BlueHDi Flair
05 C4 2.0 16v Exclusive
54 Audi A2 FSi SE
51 VW Passat V6 TDi Estate

Family Citroens:
64 C4 Cactus BlueHDi Feel Red
15 C3 Picasso 1.6HDi Exclusive
56 C5 2.0HDi 138 16v VTR Estate
95 C15 6-wheel
55 Traction 6H

User avatar
Deanxm
Posts: 3295
Joined: 18 Dec 2008, 18:57
Location: Isle of wight
My Cars: Citroen XM
x 30

Post by Deanxm » 25 May 2010, 21:32

I would say there is a leak too, the pressure has not dropped enough for the A/C to break the feed to the compressor clutch but its getting that way.
When they get regassed they always check for leaks with a vacuume test first anyway i believe so just get it booked in.
Are there any oily residue's around the hose unions or on the windscreen?

D
0x
XM Prestige 92, surgery has begun, RIP faithfull 2.0i
Mitsubishi L200 Trojan 14
Xantia Activa 95, sold (missed)

Service Citroen is awesome, it shows me pictures of all the parts i used to be able to buy............

DoubleChevron
Posts: 622
Joined: 22 Sep 2003, 18:06
Location: Australia
My Cars:

Post by DoubleChevron » 27 May 2010, 00:58

Have you checked the mixer flap in the car is working correctly ?? You can have the freezing cold air-con system, but if your heater box flap doesn't move to allow the refrigerated air in .... it'll never work :)

If you feel the compressor hoses, are the suction/discharge sides getting hot/cold ??

seeya,
Shane L.
0x
'96 Big BX 2.1TD exclusive slugomatic (aka XM)
'85 CX2500 GTi Turbo Series II (whoo hooo)
'96 Xantia VSX slugomatic (sold !!)
and of course, lots of old Citroens, slowly rusting away in pieces ;)

R9UKE
Posts: 1073
Joined: 21 Mar 2010, 22:18
Location: Belfast, N.Ireland
My Cars:

Post by R9UKE » 28 May 2010, 17:44

Thanks for advice so far, unfortunately I have very little experience when it comes to AC systems so wouldn't know where to look.

OK so today was warm. I put it to the coldest and blew the fan, pressed the AC button, but I noticed no change in engine tone or any noise, it didn't look as if the AC is kicking in at all now. But the air was cold, colder than a car without AC, but yet not cold enough for you to know it was AC.

I'm off all this week. I'll book it in somewhere and keep you updated.
0x
French is best.