Scenic compressor stuffed?

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

User avatar
demag
Donor 2016
Posts: 1436
Joined: 18 Oct 2004, 05:03

Scenic compressor stuffed?

Post by demag » 16 Apr 2010, 01:26

54 1.5dci Scenic. When I hit the a/c switch there is a little click (relay?) and nothing else. Revs don't drop and temperature stays the same. Assuming French a/c is fairly similar does anyone have a clue where to start as all my other a/c cars worked? :(

User avatar
Paul-R
Posts: 2673
Joined: 07 May 2009, 16:24

Post by Paul-R » 16 Apr 2010, 10:24

Some further information possibly needed.

Has the A/C ever worked? Or is the car new to you?

User avatar
demag
Donor 2016
Posts: 1436
Joined: 18 Oct 2004, 05:03

Post by demag » 16 Apr 2010, 13:07

I've owned it about a month so don't know too much about it. Typical dealer warranty that covers nothing. But I'm not too bothered about that and wouldn't mind having a mess about on my own. I'll have a look at the fuses tomorrow if its dry and the ash doesn't get me! :roll:

User avatar
demag
Donor 2016
Posts: 1436
Joined: 18 Oct 2004, 05:03

Post by demag » 19 May 2010, 21:29

Looks like this might be software related! :lol:

From what I've read there was a technical bulletin and some cars have been upgraded for free!

Apparently the compressor connections work loose producing a high resistance. The ecu takes this to mean the compressor has siezed and shuts off the power.

Whatever happened to switch-power-run? :roll:

User avatar
Deanxm
Posts: 3278
Joined: 18 Dec 2008, 18:57

Post by Deanxm » 19 May 2010, 21:51

Whatever happened to switch-power-run? Rolling Eyes
it was too reliable and didnt net the dealer network enough money :roll

D

User avatar
demag
Donor 2016
Posts: 1436
Joined: 18 Oct 2004, 05:03

Post by demag » 21 Jun 2010, 01:10

Update!

There were a couple of faults showing so put my trusty ELM reader to work. One said there was a problem with the throttle position sensor which was surprising as I don't think they have one! I have been told this might mean the pedal rheostat. Also EGR fault, surprise! The bain of all modern diesels :roll: . Any way, since checking these codes and attempting but failing to clear them, the a/c now attempts to work! If I hit the a/c switch on a low fan speed I can hear the engine revs drop slightly at tickover. The temperature doesn't alter though! :lol:. So next job is a recharge and then see where we go from there.

User avatar
demag
Donor 2016
Posts: 1436
Joined: 18 Oct 2004, 05:03

Post by demag » 27 Jun 2010, 22:25

Further Update!

Had it regassed at Kwik Fit! :shock: and it now works. 49 quid all in. :)