HELP

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

Post Reply
User avatar
wrinklet1
Posts: 700
Joined: 23 Nov 2002, 20:15
Location: Bolton, England
My Cars:

HELP

Post by wrinklet1 » 24 May 2009, 17:20

Help, I went to kwik fit for an aircon regas and service thingy for £45. They connected my car up( the car was cooling and had gas in it, but I was giving it a treat. They said it would take 45 mins. After it was 'done' they said my system had a leak and their machine wouldnt regas the system.....now I have a hot interior......
Any Ideas???????

Paul
0 x
1xAmi,3xGS,2xBx,2xAX,2xSaxo,1xXantia mk I,2xXantia MkII,1xC1,2xC2,

User avatar
addo
Sara Watson's Stalker
Posts: 7104
Joined: 19 Aug 2008, 12:38
Location: NEW South Wales, Australia. I'll show you "Far, far away" ;-)
My Cars: Peugeot 605
Citroën Berlingo
Alfa 147
x 1

Post by addo » 24 May 2009, 21:14

Wow. I'd be fronting the counter to ask for my money back, or if you have more determination go to a licenced non-franchised specialist and get a full diagnosis with written report first.

I personally recommend aircon repairs for winter. It helps with the screen defrost and the service techs usually aren't so busy.
0 x

User avatar
wrinklet1
Posts: 700
Joined: 23 Nov 2002, 20:15
Location: Bolton, England
My Cars:

Post by wrinklet1 » 25 May 2009, 10:18

The gauges where according to the guys showing the right settings. And yes they are tyre fitters, I wondered if the car should be running with the aircon turned on for the refill? Halfords regas says you need the aircon on when using a refill.
But, If the system has been vacuumed out, wouldnt the vacuum go if there is a leak?
the guy phoned someone to override the system to put gas in, but it took 2 mins max, and no signs of movement in the sight glass. so I wondered if maybe their machine was either faulty, no gas, or maybe the filling port blocked?????

Paul
0 x
1xAmi,3xGS,2xBx,2xAX,2xSaxo,1xXantia mk I,2xXantia MkII,1xC1,2xC2,

User avatar
Clogzz
Posts: 2062
Joined: 15 May 2005, 18:04
Location: Australia
My Cars:
x 8
Contact:

Post by Clogzz » 26 May 2009, 14:09

No signs of movement in the sight glass is normal when the system is well filled and clean.
Only at start-up are there a few small bubbles to see, then it’s all clear fluid, slightly bluish.
0 x
2003 C5 2.0i AL4 183,000 km 76372389

User avatar
wrinklet1
Posts: 700
Joined: 23 Nov 2002, 20:15
Location: Bolton, England
My Cars:

Post by wrinklet1 » 26 Jun 2009, 09:36

Ok Guys,
I had a local mobile Aircon specialist look at my cars aircon ae KwikFit not doing the job!!!!
He drained the system and nasty foam type stuff cam out. He hadnt a clue what KF had put in!!!!, He put some liquid in to clean the system out and then refilled it. Once checked he put some UV dye in it. Checked for leaks (there was non) and it also is greaan so I can see the gas/fluid in the spy hole.
£50 for the lot...........
Cool interior..........
Nice.........

Paul
0 x
1xAmi,3xGS,2xBx,2xAX,2xSaxo,1xXantia mk I,2xXantia MkII,1xC1,2xC2,

User avatar
Kowalski
Posts: 2557
Joined: 15 Oct 2003, 17:41
Location: North East, United Kingdom
My Cars: Ex 05 C5 2.0 HDI Exclusive 145k
Ex 97 Xantia 1.9TD SX 144k
Ex 94 Xantia Dimension 1.9TD 199k

Post by Kowalski » 27 Jul 2009, 12:36

Did Kwik-Fit charge you the full fee for breaking your air-con?
0 x

User avatar
wrinklet1
Posts: 700
Joined: 23 Nov 2002, 20:15
Location: Bolton, England
My Cars:

Post by wrinklet1 » 02 Aug 2009, 22:21

Hi, No, Kwik Fit didnt charge me anything, they couldnt because they advertise that they wont charge it the car isnt 10% cooler. It wasnt cold at all!!!!!

Paul
0 x
1xAmi,3xGS,2xBx,2xAX,2xSaxo,1xXantia mk I,2xXantia MkII,1xC1,2xC2,

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest