406 misting up

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

hondamt
Posts: 3
Joined: 16 Nov 2005, 16:54
Location:
My Cars:

406 misting up

Post by hondamt » 16 Nov 2005, 17:00

My 406 '98 will mist up every trip unless I keep the aircon on.
Have tried all variations of hot/cold on the controls but cant solve the problem.
Dont want to keep the aircon all the time and am sure there is no water getting into the car.
Anyone know what it could be?
Regards,
Martin.
0x

JohnD
Donor 2016
Posts: 2428
Joined: 15 Mar 2001, 00:41
Location: Epsom, Surrey
My Cars: 2010 Citroen C5-X7 tourer
1998 Citroen Saxo 1.5D
2014 Citroen C4-B7
1998 Peugeot 306
x 11

Post by JohnD » 16 Nov 2005, 19:05

You may not want to hear this - but when my daughter's two year old Xsara started doing this, it needed a new matrix (fortunately on warranty). Feel the carpets in the footwell for dampness.
0x

User avatar
fastandfurryous
Posts: 1398
Joined: 07 Jul 2004, 17:57
Location: On the road, travelling at high speed. Meep Meep.
My Cars:
x 3

Post by fastandfurryous » 16 Nov 2005, 19:28

It *might* also be that the a/c matrix is permanently wet due to being used, and isn't drying out.

Next long journey you have, run the heater hot, with a window open to prevent misting. Does is now stay demisted.

Only other alternative is that the heater is on "recirculation". Move it to fresh if this is the case.

Is there a sweet sickly smell coming from the heater? If so, then this is indeed a failed matrix. Not a fun job.
0x
This is not a signature.

PowerLee
Posts: 1256
Joined: 01 May 2004, 19:49
Location: United Kingdom
My Cars:

Post by PowerLee » 16 Nov 2005, 20:43

Hi

Check the pollen filter isn't blocked, Also check the outside air intake flap, If that comes lose it can stop airflow into the cabin & mist your windows up, Check its a tight fit on it operating peg :wink:

Had a lose air intake flap on the 405 & depending on if the nose of the car was pointing uphill or down the cabin would mist up, Superglue fixed that one.

You havent noticed any odd clicking noises from behind the glovebox lately have you?

Also is the car leaving a puddle of water when parked after the aircon has been running?

If it has then great, If it hasnt then the drain pipe is blocked.
0x
2003 Pug 206 GLX TU3JP With bloody good side impact protection!

hondamt
Posts: 3
Joined: 16 Nov 2005, 16:54
Location:
My Cars:

Post by hondamt » 17 Nov 2005, 10:18

Hi,thanks for the replys, will check them all out.
One thing I have done is removed the flap motor after it failed and put the lever into what I believed was the non recirculating position.
Guess I’ll turn it the other way and try.
Regards,
Martin.
0x

PowerLee
Posts: 1256
Joined: 01 May 2004, 19:49
Location: United Kingdom
My Cars:

Post by PowerLee » 17 Nov 2005, 19:01

Ah ha, Flap motor failure :wink:

Did your flap motor have a brown plug & 3 wires? I have a good second hand one if you want it :wink:
0x
2003 Pug 206 GLX TU3JP With bloody good side impact protection!