C5 X7 A/C cuts out after 30 secs

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

mikevybiral
Posts: 23
Joined: 02 Jul 2015, 07:44

C5 X7 A/C cuts out after 30 secs

Post by mikevybiral » 09 Jun 2019, 22:28

New to me 2008 C5 X7 2.0 HDI VTR+

Symptoms
Start engine (on tickover) with A/C on temps set to LO
After a few seconds A/C clutch cuts in
After 30 secs A/C clutch drops out

Checks/Work done so far
Clutch operation normal i.e. 12V > on, 0v > off
Regassed with 625gm R134a
No leaks
Manifold gauges show 55psi with engine off and cold. (Ambient temp around 13 degrees C)
During 30 secs run time LP drops to 25psi, HP rises to 120psi
Rad/Condenser fan runs continuously from engine start but stops soon after the clutch drops out
Climate control fan speed inconsistent with panel readings i.e. pressing speed increase/decrease buttons have no effect
Heater fan control module has been replaced but symptoms unchanged

Any advice would be appreciated.
Many thanks,
Mike

mikevybiral
Posts: 23
Joined: 02 Jul 2015, 07:44

Re: C5 X7 A/C cuts out after 30 secs

Post by mikevybiral » 14 Jun 2019, 10:50

Problem fixed. I picked up from another post that Chinese versions of the heater fan control module are often not up to the job. I managed to get my Lexia going (on my Macbook Air) and this confirmed: Permanent fault air blower supply. I did wonder if this meant the rad/condenser fan but all the same I ordered a Hella brand heater fan control module. Now all is good. Hope it lasts!

Hell Razor5543
NOT Alistair or Simon
Posts: 8997
Joined: 01 Apr 2012, 09:47
x 576

Re: C5 X7 A/C cuts out after 30 secs

Post by Hell Razor5543 » 14 Jun 2019, 10:56

Well done. If you can open up the old module you may well find some solder joins that have failed. If you have a soldering iron you probably can repair the module, and then you have a spare, just in case.